Digikeijs a Lenz

dccand
Posty: 38
Rejestracja: 29 gru 2013, 19:29

Re: Digikeijs a Lenz

Post autor: dccand »

Okazuje się, że ten problem to adresowanie troche jakby inaczej liczone przez protokoły. Jedne od 0 drugie od 1. Tak mnie sie wydaje. Uniwersalność to nie oznacza kompatybilność. Mam pewien pomysł jak przeadresowywać moduł Lr "101" aby było dobrze. Chcą aby im podać co mnie wyszło z eksperymentów. W centralce DR 5000 też trzeba uważać co jest ustawione jako adres początkowy 0 czy 1. Już się przekonałem jak przez to wszystko przesuwa się w adresach.

Awatar użytkownika
gbbsoft
Admin
Posty: 1837
Rejestracja: 09 lip 2008, 23:19
Miasto: Warszawa
System DCC: Lenz + Roco

Re: Digikeijs a Lenz

Post autor: gbbsoft »

Problem liczenia adresu od 0 czy od 1 jest jeszcze głębszy: w specyfikacji do XpressNet nie podano jak to należy liczyć (od strony użytkowników), więc różne firmy stosują różne adresowania. I tu jest mętlik. Dlatego ja zawsze sugeruje sprawdzić +1 i -1 w stosunku do podanego adresu.

dccand
Posty: 38
Rejestracja: 29 gru 2013, 19:29

Re: Digikeijs a Lenz

Post autor: dccand »

U mnie centralka DR5000 programuje adres LR101 co bit. Powinna co bajt . Jeśli jest 65 to mam w monitoringu '513' co daje w Gbbkolejce HEX 80 DEC 128 a w rezultacie 129.1(0). Jeśli jest 66 (zawsze przesuwa o 1 jakby adres a naprawdę tylko o bit cobyście nie wpisali zawsze do przodu) daje 129 też ale 129.2(0). Wyjaśniam to z Digikejis'em.
Stan dla teoretycznego 65 w Gbbkolejce 129
2020-05-18 18:21:34.9326 Otrzymano: Komenda (ff:fd:42:80:40:82)
2020-05-18 18:21:35.4126 Otrzymano: Komenda (ff:fd:42:80:41:83)
Załączniki
log.jpg

ODPOWIEDZ